О программе

Программа предназначена для автоматизации дома или офиса. Программа имеет понятный и удобный интерфейс.

Функции программы:

  • ежедневник с голосовым напоминанием;
  • список задач по проектам;
  • список контактов по категориям;
  • пульт дистанционного управления по телефону устройствами в доме;
  • телефон с автоответчиком;
  • факс с автоответчиком;
  • работа с электронной почтой на почтовом сервере;
  • ICQ пейджер;
  • IP видео-телефон.

    Персональные данные в программе можно зашифровать и защитить паролем.


Установка программы на на компьютер

Установка программы на компьютер

Для работы с системой пользователю необходимо:

Минимальные требования | Рекомендуется
Процессор
Процессор Intel Pentium 166 МГц | Intel Celeron 300
Оперативная память
32 Мбайт | 64 Мбайт
Операционная система
Windows 98/Me/2000/XP/2003a | Windows 98/Me/2000/XP/2003a
Место на жестком диске
100 Мбайт | 1 Гбайт

Для установки программы на компьютер запустите файл установки brownie.exe и следуйте инструкциям программы установки.

Выбор языка

Выберите язык установки (после установки программы его можно изменить).

Установка Brownie

Добро пожаловать в программу установки Brownie.

Эта программа установит Brownie Version на Ваш компьютер.

Настоятельно рекомендуется закрыть все открытые программы перед тем, как продолжить. Это поможет избежать некоторых ошибок во время установки.

Нажмите "Далее" для продолжения, или "Отмена" для выхода из установки.

Лицензионное соглашение

Пожалуйста, прочитайте Лицензионное соглашение. Лицензионное соглашение составлено на русском и английском языках. Далее после английского текста, следует текст Лицензионного соглашения на русском языке.

Используйте полосу прокрутки и клавишу PageDown, чтобы увидеть все соглашение.

Если Вы принимаете условия данного соглашения, выберите "Я принимаю условия соглашения" и нажмите "Далее".

Информация

Пожалуйста, прочитайте это перед тем, как продолжить Установку.

Когда Вы будете готовы продолжить Установку, нажмите "Далее".

Выбор папки для установки

Где будет установлена Brownie?

Выберите папку, в которой Вы желаете установить Brownie и нажмите "Далее".

Если программа уже установлена на компьютер и Вы желаете только обновить версию программы, программа установки спросит разрешение на установить программу в ту же папку. Выберите "Да".

Программа установки только установит новую версию и не изменит Ваши данные.

Выберите программную группу

Где будем записывать ярлык?

Выберите программную группу, в которой будут размещаться ярлыки к программе и компонентам.

Или поставьте галочку "Don't create a Start Menu folder", чтобы не создавать программную группу.

Укажите дополнительные настройки?

С какими настройками будем устанавливать?

Укажите дополнительные настройки установки Brownie.

Добавить иконки:

- создать иконку на рабочем столе

- создать иконку быстрого запуска.

Все готово к установке

Все готово к установке Brownie на Ваш компьютер.

Нажмите "Далее" для начало установки, или "Back", чтобы проверить или заново ввести информацию для установки.

Папка для установки:

C:\Program Files\Brownie

Программная группа:

The Brownie

Дополнительные настройки:

Create a desktop icon

Установка

Пожалуйста, подождите, пока программа установки устанавливает Brownie на Ваш компьютер.

Дополнительная информация

Пожалуйста, прочитайте это перед тем, как продолжить.

Когда Вы будете готовы продолжить установку, нажмите "Далее".

Завершение установки

Установка Brownie на Ваш компьютер завершена. Вы можете запустить Brownie, выбрав иконку в меню "Пуск".

Нажмите "Готово", чтобы закрыть программу Установки.

Оставьте галочку напротив "Launch Brownie", если хотите сразу же после установки запустить Brownie.

В программной группе "Генеалогическое древо" главного меню Windows будет созданы строки:

- Программа brownie.exe

- Инструкция по работе с программой

- Файл помощи

- Лицензионное соглашение

- Программа деинсталляции

Поздравляю, программа установлена!


Работа с программой

Запустите программу из панели задач "Пуск" или с рабочего стола.

После запуска системы "Домовой" на выполнение на экран выводится главное окно программы.

Верхняя строка окна называется заголовком окна. В ней выдается название программы.

Строка главного Меню

Рабочее поле программы состоит из вертикальных и горизонтальных вкладок. Вертикальная вкладка

открывает список горизонтальных вкладок.

    1. Первая вертикальная вкладка называется "Секретарь".

    2. Вторая вертикальная вкладка называется "Связь".

    3. Третья вертикальная вкладка называется "Админ"


Вкладка "Секретарь"

Первая вертикальная вкладка называется "Секретарь" и включает в себя:

    1. Горизонтальную вкладку "Ежедневник"

    2. Горизонтальную вкладку "Задачи"

    3. Горизонтальную вкладку "Контакты"

    4. Горизонтальную вкладку "Блокнот"


Ежедневник

Вкладка "Ежедневник"

Горизонтальная вкладка "Ежедневник"

предназначена для записи и оповещение о делах и встречах.

Для того чтобы внести новое событие в список нажмите кнопку

    Внесите в карточку:

  • краткое описание события;
  • выберите наименование проекта к которому относится событие;
  • введите контактное лицо;
  • введите место события;
  • введите дату и время начала события;
  • введите продолжительность события;
  • введите время за которое надо оповестить о начале события;
  • введите важность события;
  • введите процент готовности события;
  • внесите краткое описание и комментарий к событию.
    Для того чтобы сохранить событие нажмите кнопку
    Для того чтобы не сохранять событие нажмите кнопку
    Для того чтобы распечатать карточку события нажмите кнопку

Для того чтобы отредактировать событие в списке нажмите кнопку

Для того чтобы удалить событие из списка нажмите кнопку

Для того чтобы сортировать список событий по текущей колонке нажмите кнопку

Для того чтобы найти слово(а) в текущей колонке нажмите кнопку

Для того чтобы список событий нажмите кнопку


Задачи

Горизонтальная вкладка "Задачи"

предназначена для записи дел и проектов.

Для того чтобы внести новую задачу в список нажмите кнопку

    Внесите в карточку:

  • краткое описание задачи;
  • выберите наименование проекта к которому относится задача;
  • введите дату начала задачи;
  • введите дату окончание задачи;
  • введите плановые расходы времени и денег;
  • введите фактические расходы времени и денег;
  • введите важность задачи;
  • введите процент готовности задачи;
  • введите ответственную организацию и персону;
  • если задача выполнена ее можно перенести в архив;
  • внесите краткое описание и комментарий к задачи.
    Для того чтобы сохранить задачу нажмите кнопку
    Для того чтобы не сохранять задачу нажмите кнопку
    Для того чтобы распечатать карточку задачи нажмите кнопку

Для того чтобы отредактировать задачу в списке нажмите кнопку

Для того чтобы удалить задачу из списка нажмите кнопку

Для того чтобы сортировать список задач по текущей колонке нажмите кнопку

Для того чтобы найти слово(а) в текущей колонке нажмите кнопку

Для того чтобы список задач нажмите кнопку


Контакты

Горизонтальная вкладка "Контакты"

предназначена для записи сведений о лицах.

Для того чтобы внести новое событие в список нажмите кнопку

    Внесите в карточку:

  • Фамилию, Имя, Отчество;
  • дату рождения;
  • категорию контактного лица;
  • домашний адрес, телефон, факс, сотовый, e-mail, URL;
  • рабочий адрес, телефон, факс, сотовый, e-mail, URL, организация, должность;
  • если контакт уже не нужен его можно перенести в архив;
  • внесите краткое описание и комментарий к контакту.
    Для того чтобы сохранить контакт нажмите кнопку
    Для того чтобы не сохранять контакт нажмите кнопку
    Для того чтобы распечатать карточку контакта нажмите кнопку

Для того чтобы отредактировать контакт в списке нажмите кнопку

Для того чтобы удалить контакт из списка нажмите кнопку

Для того чтобы сортировать список контактов по текущей колонке нажмите кнопку

Для того чтобы найти слово(а) в текущей колонке нажмите кнопку

Для того чтобы список контактов нажмите кнопку


Блокнот

Горизонтальная вкладка "Блокнот"

предназначена для записок.


Вкладка "Связь"

Вторая вертикальная вкладка называется "Связь" и включает в себя:

    1. Горизонтальную вкладку "Пульт"

    2. Горизонтальную вкладку "Телефон"

    3. Горизонтальную вкладку "Факс"

    4. Горизонтальную вкладку "E-Mail"

    5. Горизонтальную вкладку "VoIP"

    6. Горизонтальную вкладку "ICQ"


Пульт управления домом по телефону

Для управления домом по телефону предназначен пульт во вкладке "Связь"->"Пульт". Для доступа к пульту необходимо ввести пароль во вкладке "Админ"->"Общие"->"Пароль пульта".

Работа пульта происходит следующим образом. Надо включить пульт (автоответчик в режиме меню) нажав кнопку "Включить пульт доступа по телефону". Звоним домой по телефону. Автоответчик отвечает - "Нажмите кнопку один для того чтобы оставить голосовое сообщение или нажмите кнопку два для того чтобы оставить факс". Мы нажимаем кнопку "#" (решетка). Это сигнал пульту, что надо принять пароль. Ввводим пароль. Если пароль введен верно в трубке прозвучит сигнал короткий гудок. Теперь пульт готов к принятию команд, это цифры от 1 до 8. Нажимаю ту или иную цифру от 1 до 8 мы тем самым включаем или выключаем то или иное устройство через порт LPT.

Работа с LPT-портом

Данные по LPT-порту передаются параллельно. Это значит что за один шаг передаётся один байт, в то время, как по последовательному порту за шаг передаётся один бит. Так как в одном байте восемь битов, то у нас в распоряжении сразу восемь выходов. Изначально LPT-порт предназначался для работы с принтером. Вот как используются его выводы:

  • 1 - Компьютер посылает сигнал, чтобы сообщить принтеру о готовности. При отсутствии сигнала на этом выходе, принтер не выполнит ни одной команды с других.
  • 2-9 - Выходы, по которым посылаются данные в принтер. Именно они нас и интересуют.
  • 10-17 - Входы, по которым принтер сообщает своё состояние, например, кончилась бумага.
  • 18-25 - Общий провод. Чаще всего он соединён с корпусом компьютера.

    Сигналы на выходах 2-9 - логические 0 или 1. Нам необходимо изменять состояние выводов по отдельности или вместе. Для этого нужно в порт посылать число следующим образом: каждому выводу соответствует один бит.

    Чтобы включить все выводы, нужно послать в порт число 255, чтобы выключить все - 0. Если нужно подать сигнал на несколько выводов, в порт нужно послать сумму соответствующих чисел. Для того, чтобы послать число в порт, можно использовать простейшую программу на Паскале:

    program lpttest;

var
  data:byte;

begin
  writeln(data);
  readln(data);
  port[memw[$0040:$0008]:=data;
end.

    Чтобы проверить работу программы, можно просто напрямую к порту подключить светодиод, но чтобы управлять более мощными устройствами, необходимо собрать схему согласования.

    Самая простая схема состоит из транзистора и реле. Реле можно использовать любое - исходя из напряжения питания. Единственный недостаток схемы - при внутреннем коротком замыкании транзистора напряжение питания может попасть в порт, из-за чего из строя может выйти не только контроллер порта, но и вся системная плата.

    Этого недостатка нет в схеме, собранной на оптроне.

    Он обеспечивает гальваническую развязку с портом. Схема очень проста и может управлять любыми устройствами - всё зависит от реле.

    Но лучше вообще отказаться от реле и управлять бытовой техникой, не выходя из-за компьютера.

    Устройство собрано на симисторе. В цепь оптрона включен светодиод, сигнализирующий о работе устройства. Необходимо собрать несколько (до восьми) таких устройств и разместить их в одном корпусе, например от старого сетевого фильтра, поставив около каждой розетки светодиод.

    Это не все схемы, которые можно использовать. Исходя из заданных требований, можно собрать своё устройство. Главное - не сжечь LPT-порт ПК.


Телефон

Горизонтальная вкладка "Телефон"

предназначена для совершения звонков с помощью компьютера и реализации функции автоотвечика для принятия голосовых сообщений.

Внимание, функции автоотвечика работают только с модемом поддерживающим голосовые функции.


Факс

Горизонтальная вкладка "Факс"

предназначена для принятия факсимильных сообщений с помощью компьютера и реализации функции автоотвечика для принятия факсимильных сообщений.


E-Mail

Горизонтальная вкладка "E-Mail"

предназначена для просмотра электронных писем непосредственно на почтовом сервере.


IP видео телефон

Горизонтальная вкладка "VoIP"

предназначена для видео и аудио связи между двумя компьютерами по их IP адресу.


ICQ

Горизонтальная вкладка "ICQ"

предназначена для работы в ICQ пейджере.


Вкладка "Админ"

Третья вертикальная вкладка называется "Админ" и включает в себя:

    1. Горизонтальную вкладку "Общие"

    2. Горизонтальную вкладку "Скины"

    3. Горизонтальную вкладку "Звук"

    4. Горизонтальную вкладку "Модем"

    5. Горизонтальную вкладку "Телефон"

    6. Горизонтальную вкладку "Факс"

    7. Горизонтальную вкладку "Конвертер"

    8. Горизонтальную вкладку "E-Mail"

    9. Горизонтальную вкладку "VoIP"

    10. Горизонтальную вкладку "ICQ"


Общие настройки

Горизонтальная вкладка "Общие"

предназначена для записи сведений владельце и вводе паролей.

Для того чтобы настройки нажмите кнопку


Скины

Горизонтальная вкладка "Скины"

предназначена для настройки внешнего вида программы.

Для того чтобы настройки нажмите кнопку


Настройка звука

Горизонтальная вкладка "Звук"

предназначена для настройки звукового движка, звуковой системы и звуковой карты.

Для того чтобы настройки нажмите кнопку


Настройка модема

Горизонтальная вкладка "Модем"

предназначена для настройки модема.

Для того чтобы настройки нажмите кнопку


Настройка телефона

Горизонтальная вкладка "Телефон"

предназначена для настройки телефона.

Для того чтобы настройки нажмите кнопку


Настройка факса

Горизонтальная вкладка "Факс"

предназначена для настройки факса.

Для того чтобы настройки нажмите кнопку


Конвертации факсов

Горизонтальная вкладка "Конвертор"

предназначена для настройки конвертации факсимильных сообщений из других форматов (например из текстовых файлов).

Для того чтобы настройки нажмите кнопку


Настройка электронной почты

Горизонтальная вкладка "E-Mail"

предназначена для настройки электронной почты.

Для того чтобы настройки нажмите кнопку


Настройка VoIP

Горизонтальная вкладка "VoIP"

предназначена для настройки видео и аудио связи между двумя компьютерами по их IP адресу.

Для того чтобы настройки нажмите кнопку


Настройка VoIP

Горизонтальная вкладка "ICQ"

предназначена для настройки интернет-пейджера ICQ.

Для того чтобы настройки нажмите кнопку


Лицензионное соглашение

ПРОГРАММА "ДОМОВОЙ"
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Лицензия на использование и распространение
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Copyright © 2008 Дмитрий Конюхов

Настоящий документ представляет собой лицензионное соглашение
между ООО НПФ "Перун" и конечным пользователем об использовании
базовой версии Brownie. Находящийся в пакете Brownie
лицензируется конечному пользователю на условиях настоящего
соглашения. Пожалуйста, прочитайте его. Использование Brownie
является подтверждением того, что Вы читали текст настоящего
соглашения, поняли его и принимаете его условия.

     1. ОБЪЕКТ ПРАВОВОЙ ОХРАНЫ

1.1. Всеми авторскими правами на Brownie эксклюзивно владеет
автор программы - Дмитрий Конюхов. Лицензируемый пользователю
Brownie является объектом авторского права и защищен законами
Российской Федерации. Исключительные имущественные права на
программный продукт принадлежат ООО НПФ "Перун".

1.2. Программа Brownie распространяется по принципу "попробуй
перед тем, как купить". Это означает, что вы можете использовать
эту программу на протяжении испытательного периода в 40 дней.
Если вы хотите пользоваться этой программой и дальше, то ДОЛЖНЫ
зарегистрировать свою копию программы.

1.3. Зарегистрированная копия программы Brownie может быть
использована одним лицом, которое работает с данным программным
обеспечением на одном или нескольких компьютерах, либо
установлена на одном компьютере, к которому не одновременно
имеют доступ несколько человек, но не оба варианта сразу.

1.4. После регистрации пользователю предоставляется не эксклюзивная
лицензия на использование Brownie в любых легальных целях.
Зарегистрированная копия Brownie не может быть сдана в аренду
или дана напрокат, но может быть передана в полном комплекте,
если получающее лицо согласно с данной лицензией. Если продукт
является обновлением, то помимо обновления должны быть переданы
и все предыдущие версии.

1.5. Незарегистрированная версия Brownie может
распространяться свободно (кроме случаев, оговоренных ниже)
лишь в том виде, в котором она поставляется, т.е. без всяких
изменений.

а) Никакие физические или юридические лица не имеют права
распространять отдельные части пакета без письменного разрешения
владельца авторских прав.

б) Запрещается распространять незарегистрированную версию
Brownie в комплекте других программных пакетов без письменного
разрешения владельца авторских прав.

в) Запрещается распространять Brownie на одном носителе и/или
в одном пакете программ вместе с пиратскими утилитами для "взлома",
ключевыми файлами и генераторами ключей.

1.6. Чтобы зарегистрироваться, вы должны купить Brownie.
См. подробности в файле sales.htm.

      2. ОГРАНИЧЕННАЯ ГАРАНТИЯ И ОТВЕТСТВЕННОСТЬ

2.1. Brownie РАСПРОСТРАНЯЕТСЯ ПО ПРИНЦИПУ "КАК ЕСТЬ". ПРИ ЭТОМ
НЕ ПРЕДУСМАТРИВАЕТСЯ НИКАКИХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ.
ВЫ ИСПОЛЬЗУЕТЕ ЕГО НА СВОЙ СОБСТВЕННЫЙ РИСК. НИ АВТОР, НИ ЕГО
УПОЛНОМОЧЕННЫЕ АГЕНТЫ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ПОТЕРИ ДАННЫХ,
ПОВРЕЖДЕНИЯ, ПОТЕРИ ПРИБЫЛИ ИЛИ ЛЮБЫЕ ДРУГИЕ ВИДЫ ПОТЕРЬ, СВЯЗАННЫЕ
С ИСПОЛЬЗОВАНИЕМ (ПРАВИЛЬНЫМ ИЛИ НЕПРАВИЛЬНЫМ) ЭТОЙ ПРОГРАММЫ.

2.2. ООО НПФ "Перун" гарантирует что, Brownie, если он не изменен
пользователем, будет выполнять функции, описанные в поставляемой
документации.

2.3. Вы не можете использовать, копировать, эмулировать, клонировать,
сдавать в аренду, давать напрокат, продавать, изменять,
декомпилировать, дизассемблировать, передавать лицензированную
программу или ее часть иначе, чем это описано в данной лицензии.
Любое подобное неавторизованное использование приводит к немедленному
и автоматическому прекращению действия этой лицензии и может повлечь
за собой уголовное и/или гражданское преследование.

2.4. Установка и использование Brownie свидетельствует о Вашем
согласии с условиями данной лицензии.

2.5. На незарегистрированную копию программы Brownie накладывается
ограничение - не более 10 записей.

2.6. Если вы не согласны с условиями данной лицензии, то должны удалить
файлы Brownie со своих устройств хранения информации и отказаться
от дальнейшего использования Brownie.

2.7. После оплаты Brownie Вам будет выслан по электронной почте пароль,
снимающий все функциональные ограничения. Ваш электронный адрес будет
являться логином для регистрации программы.

2.8. Зарегистрированные пользователи получают все обновления программы
Brownie бесплатно.

2.9. Все права, явно не предоставленные здесь, принадлежат Дмитрию Конюхову.

     УВЕДОМЛЕНИЯ

Все уведомления в ООО НПФ "Перун" осуществляются по следующим реквизитам:
Почта: 620023, г.Екатеринбург, а/я 65
e-mail: dvpt@narod.ru

     ЗАКЛЮЧЕНИЕ

Настоящий документ является полным соглашением об использовании Brownie
и замещает все предыдущие заявления, обсуждения, обязательства,
соглашения, сообщения или рекламные объявления относительно Brownie.

     Спасибо за использование Brownie.
     Наилучших пожеланий,
     Конюхов Дмитрий Леонидович


Техническая поддержка

Адрес программы "Генеалогическое древо семьи" в Интернете: http://www.familytree.ru

Телефон/Факс: +7 343 216-12-91
Сотовый телефон: +7-950-630-40-62
E-Mail: dvpt@narod.ru (тема письма: FamilyTree)